Ask for free help
:: home
:: add a question
:: search
:: help
:: most recent
:: unanswered
   Search: Go 
Fixed for free!
Ask Your Question

These categories may also be of interest ...

Cameras, Film Cameras

Cameras, Video Cameras

Cameras, Webcams

Full list

... mend, fix, or repair just about anything.

Help someone
  Are you good at fixing things?  

Click here to help

Fault info.
Click here for Servis repair information.
First time? costs nothing to use and you can ask a question without an account or logging in.

Click here to ask a question.


Who answers the questions?

Other users of provide the answers. The more detail and information you provide in your question the easier it is for others to help you.

Search for a fix
How can I fix my
Digital Camera?
Mend it
What does the error mean?
Categories > Mend Cameras, Digital Cameras > Question
Q & As - mend, repair, fix cameras, digital cameras, digital camera, camera, digital, film, battery, photographs, pictures, memory, card, stick, lensNavigate to ...
Cameras, Digital Cameras (1910 other questions)
Related questions - error, e45, kodak
Add a question

Mend > Digital Cameras

Question - mend, repair, fix

How can I fix an error code E45 on my Kodak Easyshare?

My Kodak Easy Share digital will not operate at all. The telephoto lens remains extended and an error code E45 is is the display. What can I do?

Roger Lee
May 2006

There is more help available. Mend - error, e45, kodak
Need to fix your Kodak Digital Camera?

To add an answer, click here To add a new question, click here To find all other questions, click here

Answers - mend, repair, fix

gave it a few sharp taps with my hand , started working , many thanks all .

September 2017

Oh my gosh! I just did the same thing and it closed. Taped it a couple of times in the palm of my hand and restarted it.

October 2016

A couple of strong taps...wahh~lah!! it works again! I hadn't used the camera since 2004! Hehe, was about to toss it! Thanks for the easy fix!

September 2016

Thanks for that! Just gave mine a little tap and hey presto!!

May 2016

Thank you to everyone who have taken the time to post their remedies to this Kodak problem.My camera had languished in my wardrobe for at least 6 months, I was going to chuck it out thinking That repair would be costly.
I found it today and looked up the error and found this website. I tried banging it against my palm to no avail. I didn't fancy getting invasive, screwdrivers etc.
I was in the kitchen so I gave the zoom a couple of gentle whacks with a wooden spoon, turned it on and off a couple of times and Yah!!!!! It worked
No invasive surgery necessary

September 2015

I had a problem with similar symptoms. I have a z760 though. Instead of E45 it says that it's overheated as soon as I turn it on, then shuts down.
I did take it apart and found what looks to be a button battery in the top section (Shoei PAS614L). It has soldered terminals. Should be bad after 10 years. I might try to replace that before I toss it out. It's only got 6 megapixels. I want something better, but it does make a long video in a very small file.

September 2014

If you are looking for an answer.... I DON'T have it here.

My first V705 had the E45 error message after I dropped it on the carpet floor. I was able to pop it to the palm of my had hard and it would start working again. That worked for a couple of months, but had to start hitting it harder and harder until eventually that did not work. I used my camera several times a week, in my job and family pics. After using it for about 4 years, I liked this camera so much that I bought the same model. It was a second hand camera but looked brand new. I have had it for about 2 years. I do not think it was ever dropped. It got out of focus while zooming in and out on a long video clip that I was taking. I tried all of the tricks mentioned here and nothing worked. Finally I started getting the E45 message and nothing after that. I took the front cover plate off along with the round lens protector cover disk. I then took off all of the screws holding down the front plate and was able to lift up the plate and lens and guts about 1/2 inch. It was enough room to blast some compressed air into the camera. I could see the gear that I assume is for the lens, along with some other stuff. I did not see any obvious dust or debris. After closing the camera, I tried it again. This time I did not get the E45. After pushing the power button it goes on to let you set the date and time. Once you click "done" the camera turns off. If you try to power up again, the lens protector disk will open for about 1 second and close again as the camera shuts off. I tried hitting all of the buttons very fast and the other tricks... nada. I am able to turn the camera on by pushing "favorites" button on top of camera. The display comes on and I can see the one "favorite" pic that I happened to have on the camera. After hitting the "favorite" button, i can then hit "Review" and view the pics on my SD card and internal memory. I am about out of ideas other than opening up the camera again and maybe getting lucky. Has anyone taken one of these apart? I am curious about if I could get inside the camera with more access to the inside by trying to remove the card that fits across the back. Anyone know? I will pass along anything new that I might find.

April 2014

I have the same problem for few months and already gave it up until last week when I was trying to throw it away. I made a final attempt. What I did was push the power button on, off, on, of ... repeatedly (the lens shutter open and close repeatedly). All of a sudden the black screen disappeared. After that I tried many times and finally figured out he trick :
1 press power button and release the button,wait for 1 second,
2, then repeatedly press the power button 4 times quickly, you will see the black screen disappear. The active live display will appear in the screen, you can take the picture normally.
You night have to try to adjust the timing of each click. Make it 1 long click, then 4 rapid clicks.
Tell me if it works . Good luck

Pierre Kwok
March 2014

It seems that throwing the camera in sea water will be best as the Kodak service station says that they can not service this model as they hv stopped the production.
The model is Kodak Easyshare V570

Can anybody confirm my action.

August 2013

cx7430 banged it against my hand it worked. Thanks.

May 2013

Tapping it also worked for me - although I soon had to tap it again. But I can tap, tap, tap as necessary.

March 2013

thankyou you people out there dosent tell you anything in the manuels about wacking it thanks again tony

May 2012

Bravissimi!!! Grazie. Funziona toccando le lenti e accendendo la fotocamera. Ovviamente per sbloccarla bisogna prima togliere e rimettere le batterie. Provare un po' di volte, con un po' di forza, due dita sulle due lenti. GRAZIEEEE!!!!

December 2011

I got my camera error code E45 to go away by turning it on and then pushing down the SCN button which is to the left of on/off button. multiple picture window come up but I hit the review button ,on the left side of the LCD display, and it was back to normal.

October 2011

Thanks for the free advice, had error code E45, followed the free advice and it worked.Tapped the lense in palm of my hand and fixed. Almost paid £18 to another website's guru. Thank you

June 2011

the error can also be fixed by taking out the battery and than switch on by pressing the favorite button (i.e the first button button from left) and than go to review the lens shutter will automatically close.

June 2011

Tapping the lens worked...thanks so much!

February 2011

Thank you so much! I was ready to trash the camera until I saw your advice. You rock!

February 2011

And here is the manual:

January 2011

Here is the solution:

January 2011

Thanks for the tips. I was about to throw it away so tapping on it wasn't a big deal.

November 2010

The Kodak troubleshooter said I would need to send the camera back to them for repair - but a gentle tap on the side of the extended lens was *all* that was needed.

What helpful people you are out there - thanks a million to Fensaddler!

September 2010

Thank you -- it is my kid's first day of school and I got this error. After tapping, well hitting, the lens with the palm of my hand, I got it to work again. Thanks so much!

September 2010

Tapping the lens worked after a few tries of turning it on and off afterwards. Thanks.

April 2010

Thank you very much... i did it. perfect...

March 2010

hey thanks so much guys!!!!
i can hardly believe it-i opened it and all that shit,and finally i tried what i didn´t dare bevore:the smack-trick

February 2010

Hey, this really works. Thank you so much.

Doug Wood
November 2009

do as it sayes above tap lens on palm of hand switch back on and hey prestyo all ok

mike w
November 2009

The sharp blow to the extended lens worked for me too! Thankyou for your help!

November 2009

Ah ha! I just tried thr techniqe of sharply smackng the lens of the camera and after 2 weeks it now retracts! ThanKs for your help! Kodak easy Share LS743 Model

August 2009

Oke its easy couse the same thing happend whit me furts search for e smal screw drifer than you take your kodak camera and the side of the disply you have to take apart and that happens whit 1 long screw onder the display thats left under and than you have 2 short ones on the side that left on the top and right on the top oke wehen you toke al those 3 screws of take that side of the camera apart and under the joistick you wil see somthing like a buten pres it in and pull it out agaian and than put your camera toggeter agaian and it wil wurk purfecly agian i hope it helpt you if you need any help just conect me add
byeee (Jonathan Vliet)

Jonathan Vliet
July 2009

Oke its easy couse the same thing happend whit me furts search for e smal screw drifer than you take your kodak camera and the side of the disply you have to take apart and that happens whit 1 long screw onder the display thats left under

Jonathan Vliet
July 2009

Firmly hit the lens on the palm of your hand and as it starts to retract give some gentle assistance. Turn off the camera and then back on and hey presto no error message displayed and the camera will work. Well it worked on my sons LS743 anyway, and at no cost!!! Thanks fensaddler for the suggestion.

May 2009

fensaddlers solution worked for my ls743; Thanks Dude :)

April 2009

August 2008

Tap the extended lens smartly in the palm of your hand. Then try pressing the button again. Its just worked for me.

November 2007

I have the same problem with my camera, I have a kodak easyshare ls743.I dont see the circular metal disk you are referring to. What model are you using? do you knowanything about my model? please help

October 2006

I took your advice and low and behold I fixed error 45, thank you so much. Just another way for Kodak to tried to rip people offff. Thanks

June 2006

Re the E45 error .... my kodak camera showed the same. Didn't have the time or patience to send it back to kodak so ... undid 3 long screws from side and 4 short ones from base - prised apart carefully and cleaned the circular metal bit which is underneath selection dial. Put camera back together again and after re-setting the date and time, it all works perfectly. Kodak are ripping us off if they make us send back camera's for expensive repair when all it needs is a clean contact with the switch... something our local camera shop could do on the spot...follow the instructions above and in five minutes the camera will be able to shot again..the difficult part of the procedure was to find a small screwdriver!! :P after that everything was a piece of tsoureki..(christmas cake in Greece hoho)

June 2006

To add an answer, click here    

Add An Answer Form

Add your answer using the form below ...

The question: How can I fix an error code E45 on my Kodak Easyshare?
Your answer:

(Add your answer here. Try to include as much detail as possible.)
Your name:

(Enter your name as you wish it to be displayed.)
Other questions in this category - Cameras, Digital Cameras
How can I fix my Lumix DMC FZ330 camera?

I purchase a Lumix DMC FZ330 camera in November 2016. It has always been kept in a camera bag. I went to use it last week and when I turned it on the small switch came away in my fingers. I sent it for a warranty repair via Jessops where I purchased the camera and have now been quoted £162 because ...

Click here for the answer
fix my camera vivitar msdc screen?

fix my camera...

Click here for the answer
meaning of msdc?

Why will my camera not work but has MSDC on the screen...

Click here for the answer
how can fix my pentax 0ptio e60 10.1 megapixals camrea?

how can fix my pentax 0ptio e60 10.1 megapixals camrea...

Click here for the answer
how can i fix my Sony DSC-380?

I have recharged the battery On switch On the lens will not extend...

Click here for the answer
320 Road Runner dash camera?

Prestigio 320 Road Runner dash camera only had it from Argos 3 days ago from so not had chance to use it in car yet. Two problems 1.When connected to PC the camera comes on automatic, when unplugged it turns off.(Battery full charged). The problem:- When hand held and manually turned on by ...

Click here for the answer
camera wont send photographs to laptop?

I own a Fujifilm finepix S4500 camera which is not sending photographs to laptop once laptop is on and usb cables are turned connected. I proceed to depress the button at button right corner of camera and get no indication on display at back of camera that usb is working.The button has an arrow poi...

Click here for the answer
My Lumix DMC-TZ30 has done the same thing. How do I fix it?

My Lumix DMC-TZ30 suddenly came up with System Error (zoom) half way through our 4 week holiday in Italy. Very grumpy about this as I want to record our experiences on this trip. (We're from New Zealand). I've had earlier Lumix cameras and they have come with me on skiing, tramping, fishing holidays...

Click here for the answer
Fix what?
Kitchen Appliances, Food Processors - fix/mend/repair/service information
Furnishings, Laminate Flooring - fix/mend/repair/service information
Cooling, Fans - fix/mend/repair/service information
Help wanted!
I was about to give up and pay an electrician a call out fee.

Dec 2017

Mend it
How can I mend my immersion?
All appliances!

To mend any household, kitchen, or other electrical appliance start here.

To search for repair advice click here.

To find out how to mend it click here.

Mend it
What does the error mean?
Fault find
Click here to fix Husqvarna products.

Attempting repairs can be dangerous.
In many instances work should only be undertaken by a qualified professional.
Ensure you have read our Small Print page before using information supplied via this website.

©  2003 vD
We use Cookies. See our Privacy Policy.